Topic: Imgur 'Authorization Failed'??

Trying to link my Imgur account (which I log into using Twitter credentials; not sure if that's pertinent) but every time I click the 'allow access' button with 'log in using Twitter' selected, it thinks about it for a while, even displays my Twitter header for a split second, but then tells me:

Authorization Failed

Failed to link your account. Try clicking the 'Link Account' button again and ensure you login and click the 'Allow' button.


I've tried it several times but no luck. Any ideas??

Re: Imgur 'Authorization Failed'??

Hmmm, yep same problem here. And yes it's caused by authenticating via Twitter, it works fine if authenticating via a normal Imgur account. I'm looking into it now, hope to have a fix for you soon.

Re: Imgur 'Authorization Failed'??

Thanks John! Awesome.

Re: Imgur 'Authorization Failed'??

OK, I've fixed it. Looks like there were some changes at Imgur and a bug in OAuth was introduced that I've had to do a workaround for. Here's a beta version of Dropzone 3.5 you can download with the fix:

http://shipsomecode.com/misc/Dropzone-3.5-Build763.zip

You should close and trash your current version of Dropzone first. You can stick with this version and you'll still receive an auto-update to the final build of 3.5 when it is released.

Let me know if this fixes it for you smile

Re: Imgur 'Authorization Failed'??

I'm having issues with OAuth sign-in for Imgur, as well. I've downloaded and installed the nightly that you linked to above, but no dice. Clicking on the icons for the various OAuth login options does nothing. I viewed the console, but no errors are thrown with the exception of a 404 for a css file on imgur.

Dropbox Version: 3.5 (763)
Mac Version: 10.10.3

Want any additional info?

Re: Imgur 'Authorization Failed'??

Update: It's just the Google+ OAuth flow. Proceeding results in this:

Error: invalid_request

Invalid response_type: token?client_id=...

Re: Imgur 'Authorization Failed'??

I linked my account by using an intercepting proxy and manually manipulating the OAuth flow. Looks like it's an imgur issue:

Imgur responds the webkit client with a 302 for accounts.google.com:

https://accounts.google.com/o/oauth2/auth?scope=https://www.googleapis.com/auth/userinfo.email%20https://www.googleapis.com/auth/plus.login&state=http://api.imgur.com/oauth2/authorize?client_id=09119b67d9cb8e2&response_type=token&redirect_uri=https://imgur.com/signin/google_plus_callback&response_type=code&client_id={redacted}

The problem is that this causes the flow to break down:

state=http://api.imgur.com/oauth2/authorize?client_id=09119b67d9cb8e2&response_type=token

Removing the client_id from the state parameter allows the flow to proceed:

https://accounts.google.com/o/oauth2/auth?scope=https://www.googleapis.com/auth/userinfo.email%20https://www.googleapis.com/auth/plus.login&state=http://api.imgur.com/oauth2/authorize?response_type=token&redirect_uri=https://imgur.com/signin/google_plus_callback&response_type=code&client_id={redacted}

The OAuth flow proceeds on Google's side, allowing me to login. Then it redirects me back to imgur, but without the client_id in the response token, which causes webkit to go into a recursive loop that concatenates response_type=token a gazillion times over. I can finish off the flow by manually issuing the request that imgur is expecting:

GET /oauth2/authorize?response_type=token&client_id=09119b67d9cb8e2

Hopefully that should help you with the fix. Good luck!

Re: Imgur 'Authorization Failed'??

Thanks for that Jonathon!

I'm going to wait a bit and see if Imgur fix this themselves. It's just the Google OAuth method that's broken just now - all the other methods (Facebook, Twitter and Yahoo) are currently working. If it's not fixed soon then I will implement the workaround in Dropzone you have suggested.

For any others looking for help with this, first make sure you download the beta build from:

http://shipsomecode.com/misc/Dropzone-3.5-Build763.zip

Then choose an authorization method other than G+ for the time being. Using a proper Imgur account or choosing Twitter, Facebook or Yahoo methods should all authorize fine.

Re: Imgur 'Authorization Failed'??

Hey, just saw this update (didn't have notifications turned on for some reason). Works great for me with Twitter! :-) Thanks.