Topic: Error saving FTP password in keychain


I receive the following error as I try to set up the FTP service. I've tested the connection (it's fine); I've tried creating a new keychain; I've made a second FTP account and receive the same error; I've tried entering the account directly into Keychain. I'm not really sure how to troubleshoot this further. The username and password are correct.

Failed to store login for service with account in keychain.

Error Domain=com.samsoffes.sskeychain Code=-25293 "The user name or passphrase you entered is not correct." UserInfo=0x600001077e80 {NSLocalizedDescription=The user name or passphrase you entered is not correct.}

Thanks for any help, either solutions or just pointing me in the right direction! I'm fairly new to OSX so have less intuitive sense of how to troubleshoot.

Re: Error saving FTP password in keychain

Well, I've sort-of solved this by making a different Keychain the default. Still sort of inconvenient, I'm not sure why the default Keychain won't take the account...

Re: Error saving FTP password in keychain

I've had this once or twice during debugging and found it's usually fixed by relaunching Dropzone 3.

I think it can happen if Dropzone tries to access your keychain and you cancel the prompt or put in the wrong password. Then Dropzone is blocked from accessing the keychain and can't store or retrieve passwords until relaunch. This may not be the same issue, but try a relaunch first.

If the problem persists, open (in the Applications/Utilities folder) and do a search for any messages with 'Dropzone' in them and email these to me - and I'll get into it further.